0
votes

Now before anyone says "No one can help you with that" please understand that the upgrade worked, this is just a weird bug.

Ok so I upgraded Joomla from 2.5.14 successfully and everything works, nothing out of the ordinary. Every component/module/plugin seems to be working as it should.

HOWEVER the extension manager has a strange behavior, it constantly says:

-1 Copy file failed

I would think file permission problems, but everything is writable. The wierdest thing is it actually installed perfectly, just get this error rather then it saying it worked. (Meaning that when I install the component, there is no error).

This also only happens with components.

Just strange, might be worthy of diving deeper into it in case others run into this with an upgrade. I do not know enough about how the extension manager works to try to identify the problem either, and the lack of a real (or accurate) error message makes it even harder. (the files did copy, so that error message seems out of place)

I will try to look a little deeper in it and see if I cannot isolate it, For those who want to try to recreate it, you can do it by upgrading from 2.5.14 to 3.1.5 though the update manager. The main components I have are no number extension manager, akeeba and admin tools that I feel might have something to do with it.

2
Not sure if you submitted a bug report on the bug tracker for Joomla, but that would likely get you a better response. - David Fritsch
did you check the apache and php error logs? might find some trace there... - Riccardo Zorn
Because it is from an upgrade I am hesitant to put in a bug report, 90% of those get ignored anyway (so many that are due to user error and not an actual bug). So I would like to find grounds to say this is a legitimate problem first. Also for error logs, looked but seen nothing out of the ordinary. - Jordan Ramstad

2 Answers

1
votes

That most likely is a permissions issue. That error is a RuntimeException thrown by the JFolder class method copy() while trying to copy a file into a folder - src_folder/file to dest_folder/file.

Check your FTP settings in global configuration and then the directories permissions.

0
votes

I had this error with my module and I did several tests. I removed one level to my image directories from my module and the upgrade finally work...