0
votes

i have created a simple asp.net application which runs fine locally.

I have uploaded the application to my website and ran through as error saying

" It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an appliction."

this error was due to the fact that the subfolder i uploaded my application to is not configured as an application in the webserver (IIS ? maybe) and therefore i can't have multiple config files.

i solved this issue by moving some entries from the subfolder config file to the root config file.

HOWEVER, THIS HAS INTRODUCED ANOTHER ERROR.

Server Error in '/' Application.

Parser Error Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

Parser Error Message: Could not load type 'CvForm._Default'.

Source Error:

Line 1: <%@ Page Title="Home Page" Language="C#" MasterPageFile="~/Site.master" AutoEventWireup="true" Line 2:
CodeBehind="Default.aspx.cs" Inherits="CvForm._Default" %> Line 3:

Source File: /CvForm/Default.aspx Line: 1

-------------------------------------------------------------------------------- Version Information: Microsoft .NET Framework Version:2.0.50727.3625; ASP.NET Version:2.0.50727.3634

I have been trying for the last 4-5 hrs to solve this issue with no luck.

I will appreciate someone pointing me to a way to solve this issue. ( im sure im doing something the wrong way.. I'm new to asp.net world! ).

Kindest Regards, Aamran

1
I have found the problem! .. since i have moved my webconfig to the root folder now my application expects DLL files to be in the bin folder of the root and no the subfolder. All i had to was to copy all content from the subfolder's bin to the root's bin. Sorry for bothering you with a tedious mistake. (Though, hopefully some1 will benefit from this! ). - aamran

1 Answers

1
votes

if your web site does not run on the remote server, be sure you have deploye all the project dependency. Take a look at the project references and be sure you deployed all the dll.