0
votes

Im trying to deploy Octavia in Kolla Openstack, my global.yml is:

config_strategy: "COPY_ALWAYS"
kolla_base_distro: "ubuntu"
kolla_install_type: "source"
kolla_internal_vip_address: "169.254.1.11"
network_interface: "eth0"
neutron_external_interface: "eth1"
neutron_plugin_agent: "openvswitch"
enable_neutron_provider_networks: "yes"
enable_haproxy: "yes"
enable_cinder: "yes"
enable_cinder_backend_lvm: "yes"
keystone_token_provider: 'fernet'
cinder_volume_group: "openstack_cinder"
nova_compute_virt_type: "kvm"
enable_octavia: "yes"
octavia_network_interface: "eth2"

I use a default/automatic configuration, keypair, network and flavor are created in service project. Then I create the amphora image for this project.

All this is indicated in the Openstack guide, but it doesn't work.

When I create a loadbalancer, the amphora is deployed but the loadbalancer is "Pending Create" status. I saw that the created network is vxlan, a tenant network, and I think that it should have external conectivity, I tried but didn't work.

I check the openvswitch configuration and don't see any difference deploying with or without Octavia.

Do I miss something? I don't know what to do at this point, I even tried the manual config but I couldn't make it work.

1

1 Answers

0
votes

I can't speak to the kolla part of this issue, but with the load balancer in PENDING_CREATE, the controller (worker) logs should show where it is retrying to take some action against your cloud and failing. It will retry for some time, then move to an ERROR status if the cloud issue is not resolved in time.

Without seeing the logs, my guess is kolla did not setup the lb-mgmt-net correctly.