I cannot to access to my private Cloud SQL for SQL Server instance from Data Fusion.
I read documentation and I followed all these steps:
- created Cloud SQL for SQL Server instance with private IP on default network
- created Data Fusion instance with private IP on default network
- created peering connection between Data Fusion on default network
- checked peering connection between Cloud SQL on default network
- granted to SQL Client role to Data Fusion services account
- created a firewall rule to allow traffic from Data Fusion private IP class to default network
- installed sql server jdbc drivers on Data Fusion
I'm able to connect to Cloud SQL for SQL Server instance using its private IP from a vm instance bu I cannot connect to same instance from Data Fusion.
Data Fusion returns a timeout error.
Error: Connection timed out: no further information. Verify the connection properties. Make sure that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port. Make sure that TCP connections to the port are not blocked by a firewall.
For MySQL and Postgres there are specific connectors for Cloud SQL but not for SQL Server.
There is someone that has successfully connected a Cloud SQL for SQL Server instance to Data Fusion by private ip?