0
votes

I am trying to create a cinder storage with a size of 5Gb and I get the following error.

# cinder create 5 --display-name FileStorage
ERROR: Version 3.52 is not supported by the API. Minimum is 3.0 and maximum is 3.50. (HTTP 406) (Request-ID: req-cc838137-0b60-4e72-8abe-a679a55aa399)

Is there any way I could get the cinder created ? I cannot change settings in openstack as I am not an admin. How do I go back version to 3.50 ?

1
Try using the openstack client instead. docs.openstack.org/python-openstackclient/pike/cli/… - eandersson
I am using open stack client - newbieCoder
I solved it by setting OS_VOLUME_API_VERSION env variable to 3.50. - newbieCoder
OpenStack client command would look something like this > openstack volume create FileStorage --size 5 - eandersson

1 Answers

0
votes

Change the API version that cinder will use by setting an environment variable :

export OS_VOLUME_API_VERSION=3.50