0
votes

We have approx 12 databases(including system databases) in support of our product. We have a job that takes FULL backup of each database weekly once(Sunday), differential each day and transactional every 4 hours.

One of my client is getting following error in job history, during FULL backup job execution.

Message:

Executed as user: domain\user. Cannot open backup device 'bakup_device_name(\absolute path\msdb.bak)'. Operating system error 32(failed to retrieve text for this error. Reason: 15105). [SQLSTATE 42000](Error 3201) BACKUP DATABASE is terminating abnormally. [SQLSTATE 42000](Error 3013). The step failed.

Please help me the different approaches to find the root cause of the issue and solution for the issues.

1

1 Answers

1
votes

MS SQL error 15105 is an error message which occur when a user try to create database file backup to a network shared disk or when hosting database file on a network share is not supported, and as a result such error message event take place.

The possible reasons and hoe to fix it here: WHAT IS MS SQL ERROR 15105 ?