I spent last 2 days trying to find the solution to my issue.
HTTP works fine http://jackrus.net, but HTTPS won't work.
1.I created an instance on Amazon Linux EC2. 2.Redirected my domain jackrus.net to my public IP 3. Opened listeners 443, 22, 80. (security groups) 4. Followed the instructions from aws documentation from here 5. Checked all permissions 6. apachectl -t - says syntax is fine. 7. Restarted the server. no problem here too.
Here is my ssl.conf
.... .... .... SSLCertificateFile /etc/pki/tls/certs/certificate.crt
SSLCertificateKeyFile /etc/pki/tls/private/private1.key
SSLCACertificateFile /etc/pki/tls/certs/intermediate.crt ... ... ...
The response i get here: This site can’t be reached
jackrus.net refused to connect. Try: Checking the connection Checking the proxy and the firewall ERR_CONNECTION_REFUSED