0
votes

I am having issue with replace or executing stored procedure in teradata. This error suddenly appears. The stored procedure I have created before does not work at all suddenly.

When I try to replace a procedure I am getting Error 5547: failed to get the file size and when try to execute an existing procedure I get Error 7645: RTSExecSP: Error writing into file. This procedure worked fine previously. I am using TD 15.00.02.06.

I have looked into the error definition for 7645 error in the TD site and it says that:

"This error is reported when a problem is encountered while writing into the stored procedure object code file or log files during SP or DB spoil operations. This can occur when the directory has no space. This is a system disk directory NOT part of the database."

Can anyone suggest me where in the TD OS I should look for this space?

here is a simple stored procedure I tried to compile

CREATE PROCEDURE [MyDb].InsertSalary ( 
   IN in_EmployeeNo INTEGER, IN in_Gross INTEGER, 
   IN in_Deduction INTEGER, IN in_NetPay INTEGER

) 
BEGIN 
   INSERT INTO [MyDb].Salary ( 
      EmployeeNo, 
      Gross, 
      Deduction, 
      NetPay 
   ) 
   VALUES ( 
      :in_EmployeeNo, 
      :in_Gross, 
      :in_Deduction, 
      :in_NetPay 
   ); 
END;
1

1 Answers

0
votes

Earlier I faced same issue...I talked with my DBA...he made changes in permission level..it worked for me...