We're using Kubernetes 1.3.6 on AWS Currently we have a single DNS pod of the cluster addon on the system namespace. If the node which the pod runs on fails for some reason the cluster's DNS service is shut down and most of it can't work correctly.
My question is: How can I setup a more robust DNS service? Can I just kubectl scale the replication controller for more pods? Will that work?