0
votes

I'm having the following error :

@riak_kv_vnode:maybe_create_hashtrees:178 riak_kv/456719261665907161938651510223838443642478919680: unable to start index_hashtree: {error,{{bad match,{error,{db_open,"Corruption: truncated record at end of file"}}}

Full log here : http://pastebin.com/Lgaqw2Wu

Running Version : Riak : riak_2.0.2-1_amd64.deb

OS : Distributor ID: Ubuntu Description: Ubuntu 14.04.1 LTS Release: 14.04 Codename: trusty

Tried vnode repair , partition repair , node restart and i traced the code to a function that initialises the LevelDB , its clear there is a corruption on our hashtree.

Hoping some can give a tip.

Regards

1
Is this a programming question, or would it be better served one of the sister sites like serverfault.com? - Joe

1 Answers

2
votes

Hashtrees are used for anti-entropy exchanges. If you have a corrupt file in your hashtree it is probably for the best to simply delete the files for that tree and allow them to rebuild.

There should be an anti_entropy directory in your data directory that contains these files, if you delete the files and restart Riak, it should be able to rebuild those from scratch.