0
votes

I'm trying to get XAMPP working on Win7/64 for testing Wordpress themes.

I was originally getting a problem with Apache trying to access Port 80 but I was told to change the config file to port 81 which I have done and now Apache is running and localhost:81 shows the XAMPP control panel fine.

However, now MySQL is not working at all. Before I changed the config file, I think it was, but Apache was not running so I still couldn't access localhost at all.

In Windows Event Viewer, I am getting this Error report on the MySQL:

Fatal error: Can't open and lock privilege tables: Can't find file: 'host' (errno: 2)

In XAMPP's console I am currently getting this:

17:07:36  [main]    Initializing Control Panel
17:07:36  [main]    Windows Version: Windows 7 Ultimate SP1 64-bit
17:07:36  [main]    XAMPP Version: 1.8.1
17:07:36  [main]    Control Panel Version: 3.1.0 3.1.0 [ Compiled: September 20th 2012 ]
17:07:36  [main]    Running with Administrator rights - good!
17:07:36  [main]    XAMPP Installation Directory: "c:\xampp\"
17:07:37  [main]    Checking for prerequisites
17:07:37  [main]    All prerequisites found
17:07:37  [main]    Initializing Modules
17:07:37  [Apache]  Problem detected!
17:07:37  [Apache]  Port 80 in use by "system"!
17:07:37  [Apache]  Apache WILL NOT start without the configured ports free!
17:07:37  [Apache]  You need to uninstall/disable/reconfigure the  blocking application
 17:07:37  [Apache]     or reconfigure Apache to listen on a different port
17:07:37  [Apache]  XAMPP Apache is already running on port 443
17:07:37  [main]    Starting Check-Timer
17:07:37  [main]    Control Panel Ready
17:07:40  [mysql]   Attempting to start MySQL app...
17:07:40  [mysql]   Status change detected: running
17:07:41  [mysql]   Status change detected: stopped
17:07:41  [mysql]   Error: MySQL shutdown unexpectedly.
17:07:41  [mysql]   This may be due to a blocked port, missing dependencies, 
17:07:41  [mysql]   improper privileges, a crash, or a shutdown by another method.
17:07:41  [mysql]   Check the "/xampp/mysql/data/mysql_error.log" file
17:07:41  [mysql]   and the Windows Event Viewer for more clues
17:07:47  [mysql]   Attempting to start MySQL app...

and here is the error log for MySQL:

130301 16:28:14 [Note] Plugin 'FEDERATED' is disabled.
InnoDB: The InnoDB memory heap is disabled
InnoDB: Mutexes and rw_locks use Windows interlocked functions
InnoDB: Compressed tables use zlib 1.2.3
130301 16:28:14  InnoDB: Initializing buffer pool, size = 16.0M
130301 16:28:14  InnoDB: Completed initialization of buffer pool
130301 16:28:14  InnoDB: highest supported file format is Barracuda.
130301 16:28:15  InnoDB: 1.1.4 started; log sequence number 1595675
130301 16:28:15 [ERROR] Fatal error: Can't open and lock privilege tables: Can't find file: 'host' (errno: 2)
130301 16:28:43 [Note] Plugin 'FEDERATED' is disabled.
InnoDB: The InnoDB memory heap is disabled
InnoDB: Mutexes and rw_locks use Windows interlocked functions
InnoDB: Compressed tables use zlib 1.2.3
130301 16:28:43  InnoDB: Initializing buffer pool, size = 16.0M
130301 16:28:43  InnoDB: Completed initialization of buffer pool
130301 16:28:43  InnoDB: highest supported file format is Barracuda.
130301 16:28:43  InnoDB: 1.1.4 started; log sequence number 1595675
130301 16:28:43 [ERROR] Fatal error: Can't open and lock privilege tables: Can't find file: 'host' (errno: 2)
130301 16:28:51 [Note] Plugin 'FEDERATED' is disabled.
InnoDB: The InnoDB memory heap is disabled
InnoDB: Mutexes and rw_locks use Windows interlocked functions
InnoDB: Compressed tables use zlib 1.2.3   
130301 16:28:51  InnoDB: Initializing buffer pool, size = 16.0M
130301 16:28:51  InnoDB: Completed initialization of buffer pool
130301 16:28:51  InnoDB: highest supported file format is Barracuda.
130301 16:28:52  InnoDB: 1.1.4 started; log sequence number 1595675
130301 16:28:52 [ERROR] Fatal error: Can't open and lock privilege tables: Can't find file: 'host' (errno: 2)
130301 16:30:07 [Note] Plugin 'FEDERATED' is disabled.
InnoDB: The InnoDB memory heap is disabled
 InnoDB: Mutexes and rw_locks use Windows interlocked functions
 InnoDB: Compressed tables use zlib 1.2.3
 130301 16:30:07  InnoDB: Initializing buffer pool, size = 16.0M
130301 16:30:07  InnoDB: Completed initialization of buffer pool
130301 16:30:07  InnoDB: highest supported file format is    Barracuda.
130301 16:30:07  InnoDB: 1.1.4 started; log sequence number 1595675
130301 16:30:07 [ERROR] Fatal error: Can't open and lock privilege tables: Can't find file: 'host' (errno: 2)
130301 16:30:35 [Note] Plugin 'FEDERATED' is disabled.
InnoDB: The InnoDB memory heap is disabled
InnoDB: Mutexes and rw_locks use Windows interlocked functions
InnoDB: Compressed tables use zlib 1.2.3
130301 16:30:35  InnoDB: Initializing buffer pool, size = 16.0M
130301 16:30:35  InnoDB: Completed initialization of buffer pool
130301 16:30:35  InnoDB: highest supported file format is Barracuda.
130301 16:30:35  InnoDB: 1.1.4 started; log sequence number 1595675
130301 16:30:35 [ERROR] Fatal error: Can't open and lock privilege tables: Can't find file: 'host' (errno: 2)
130301 16:30:43 [Note] Plugin 'FEDERATED' is disabled.
InnoDB: The InnoDB memory heap is disabled
InnoDB: Mutexes and rw_locks use Windows interlocked functions
InnoDB: Compressed tables use zlib 1.2.3
130301 16:30:43  InnoDB: Initializing buffer pool, size = 16.0M
130301 16:30:43  InnoDB: Completed initialization of buffer pool
130301 16:30:43  InnoDB: highest supported file format is Barracuda.
130301 16:30:43  InnoDB: 1.1.4 started; log sequence number 1595675
 130301 16:30:43 [ERROR] Fatal error: Can't open and lock privilege tables: Can't find file: 'host' (errno: 2)
130301 16:30:56 [Note] Plugin 'FEDERATED' is disabled.
 InnoDB: The InnoDB memory heap is disabled
InnoDB: Mutexes and rw_locks use Windows interlocked functions
InnoDB: Compressed tables use zlib 1.2.3
 130301 16:30:56  InnoDB: Initializing buffer pool, size = 16.0M
130301 16:30:56  InnoDB: Completed initialization of buffer pool
130301 16:30:56  InnoDB: highest supported file format is Barracuda.
130301 16:30:57  InnoDB: 1.1.4 started; log sequence number 1595675
130301 16:30:57 [ERROR] Fatal error: Can't open and lock privilege tables: Can't find file: 'host' (errno: 2)
130301 16:30:59 [Note] Plugin 'FEDERATED' is disabled.
 InnoDB: The InnoDB memory heap is disabled
 InnoDB: Mutexes and rw_locks use Windows interlocked functions
InnoDB: Compressed tables use zlib 1.2.3
130301 16:30:59  InnoDB: Initializing buffer pool, size = 16.0M
130301 16:30:59  InnoDB: Completed initialization of buffer pool
130301 16:30:59  InnoDB: highest supported file format is Barracuda.
 130301 16:30:59  InnoDB: 1.1.4 started; log sequence number     1595675
  130301 16:30:59 [ERROR] Fatal error: Can't open and lock privilege tables: Can't find file: 'host' (errno: 2)
 130301 16:31:00 [Note] Plugin 'FEDERATED' is disabled.
InnoDB: The InnoDB memory heap is disabled
InnoDB: Mutexes and rw_locks use Windows interlocked functions
InnoDB: Compressed tables use zlib 1.2.3
130301 16:31:00  InnoDB: Initializing buffer pool, size = 16.0M
130301 16:31:00  InnoDB: Completed initialization of buffer pool
 130301 16:31:00  InnoDB: highest supported file format is Barracuda.
130301 16:31:01  InnoDB: 1.1.4 started; log sequence number 1595675
 130301 16:31:01 [ERROR] Fatal error: Can't open and lock privilege tables: Can't find file: 'host' (errno: 2)
 130301 16:31:02 [Note] Plugin 'FEDERATED' is disabled.
InnoDB: The InnoDB memory heap is disabled
 InnoDB: Mutexes and rw_locks use Windows interlocked functions
 InnoDB: Compressed tables use zlib 1.2.3
 130301 16:31:02  InnoDB: Initializing buffer pool, size = 16.0M
 130301 16:31:02  InnoDB: Completed initialization of buffer pool
 130301 16:31:02  InnoDB: highest supported file format is Barracuda.
 130301 16:31:02  InnoDB: 1.1.4 started; log sequence number      1595675
 130301 16:31:02 [ERROR] Fatal error: Can't open and lock privilege tables: Can't find file: 'host' (errno: 2)
 130301 17:00:46 [Note] Plugin 'FEDERATED' is disabled.
 InnoDB: The InnoDB memory heap is disabled
 InnoDB: Mutexes and rw_locks use Windows interlocked functions
 InnoDB: Compressed tables use zlib 1.2.3
 130301 17:00:46  InnoDB: Initializing buffer pool, size = 16.0M
 130301 17:00:46  InnoDB: Completed initialization of buffer pool
 130301 17:00:46  InnoDB: highest supported file format is Barracuda.
 130301 17:00:47  InnoDB: 1.1.4 started; log sequence number  1595675
 130301 17:00:47 [ERROR] Fatal error: Can't open and lock privilege tables: Can't find file: 'host' (errno: 2)
130301 17:07:40 [Note] Plugin 'FEDERATED' is disabled.
 InnoDB: The InnoDB memory heap is disabled
 InnoDB: Mutexes and rw_locks use Windows interlocked functions
 InnoDB: Compressed tables use zlib 1.2.3
 130301 17:07:40  InnoDB: Initializing buffer pool, size = 16.0M
 130301 17:07:40  InnoDB: Completed initialization of buffer pool
 130301 17:07:40  InnoDB: highest supported file format is Barracuda.
 130301 17:07:40  InnoDB: 1.1.4 started; log sequence number 1595675
 130301 17:07:40 [ERROR] Fatal error: Can't open and lock privilege tables: Can't find file: 'host' (errno: 2)
 130301 17:07:47 [Note] Plugin 'FEDERATED' is disabled.
 InnoDB: The InnoDB memory heap is disabled
 InnoDB: Mutexes and rw_locks use Windows interlocked functions
  InnoDB: Compressed tables use zlib 1.2.3
 130301 17:07:47  InnoDB: Initializing buffer pool, size = 16.0M
 130301 17:07:47  InnoDB: Completed initialization of buffer pool
 130301 17:07:47  InnoDB: highest supported file format is Barracuda.
 130301 17:07:47  InnoDB: 1.1.4 started; log sequence number 1595675
 130301 17:07:47 [ERROR] Fatal error: Can't open and lock privilege tables: Can't find file: 'host' (errno: 2)

Is there a config file I need to change to match the Apache file? There's nothing obvious I can see.

Many thanks in advance.

2
that port 80 issue might have been that skype is running (it uses port 80). for mysql i cant help you, the default port is 3306, run a port scanner to check open ports on your system. or read the /xampp/mysql/data/mysql_error.log. or maybe you have another webserver with mysql running (check your services) - x4rf41
Wasn't Skype, I don't have it. Will update question to include text of the error log. - sanjaypoyzer
You can run netstat -aon, get PID and lookup the app with that identifier. - Grigorii Chudnov
Ok thanks, I've done that and found the Image Name in question is just called "System". Sounds a bit ominous. What does this mean? - sanjaypoyzer

2 Answers

1
votes

Ended up solving the problem by uninstalling XAMPP, reinstalling it again and then changing the port that Apache uses from 80 to 8080.

-2
votes

Hey I just did this and it worked:

  1. exit Xampp server
  2. go to your C:\xampp\mysql\data directory
  3. delete the ibdata1 file
  4. restart xampp server