I am installing mysql-5.5.13.tar.gz in debian 6.0.4. I am following the steps from here When I run the step
scripts/mysql_install_db --user=mysqlI get the exception that
bash: scripts/mysql_install_db: No such file or directory
But file exist in the place. I made that executable too but its not working. I was working in the root terminal. Please help me to resolve this problem.
Thanks
I installed
mysql-5.5.24-linux2.6-i686.tar.gzNow after executing command
root@server06:/usr/local/mysql# scripts/mysql_install_db --user=mysqlI got the message
Installing MySQL system tables... ./bin/mysqld: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directoryInstallation of system tables failed! Examine the logs in ./data for more information.
You can try to start the mysqld daemon with:
shell> ./bin/mysqld --skip-grant &and use the command line tool ./bin/mysql to connect to the mysql database and look at the grant tables:
shell> ./bin/mysql -u root mysql mysql> show tablesTry 'mysqld --help' if you have problems with paths. Using --log gives you a log in ./data that may be helpful.
Please consult the MySQL manual section 'Problems running mysql_install_db', and the manual section that describes problems on your OS. Another information source are the MySQL email archives available at http://lists.mysql.com/.
Please check all of the above before mailing us! And remember, if you do mail us, you MUST use the ./bin/mysqlbug script!
and mysql is not started. Please help me should I download another one?
I installed "libaio" using apt-get then it was successfully installed. but when i started mysql using command
bin/mysqld_safe --user=mysql &I got the message
root@server06:/usr/local/mysql# bin/mysqld_safe --user=mysql 120514 16:10:11 mysqld_safe Logging to '/var/lib/mysql/server06.err'. 120514 16:10:11 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql 120514 16:10:13 mysqld_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended
In the /var/lib/mysql/server06.err file I found following
20514 16:15:49 [Note] 120514 16:15:49 mysqld_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended 120514 16:17:57 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql 120514 16:17:57 [ERROR] Can't find messagefile '/usr/share/mysql/english/errmsg.sys' 120514 16:17:57 [Note] Plugin 'FEDERATED' is disabled. 120514 16:17:57 InnoDB: The InnoDB memory heap is disabled 120514 16:17:57 InnoDB: Mutexes and rw_locks use InnoDB's own implementation 120514 16:17:57 InnoDB: Compressed tables use zlib 1.2.3 120514 16:17:57 InnoDB: Using Linux native AIO 120514 16:17:57 InnoDB: Initializing buffer pool, size = 128.0M 120514 16:17:57 InnoDB: Completed initialization of buffer pool 120514 16:17:57 InnoDB: highest supported file format is Barracuda. 120514 16:17:57 InnoDB: Waiting for the background threads to start 120514 16:17:58 InnoDB: 1.1.8 started; log sequence number 1595675 120514 16:17:58 [ERROR] Aborting 120514 16:17:58 InnoDB: Starting shutdown... 120514 16:17:59 InnoDB: Shutdown completed; log sequence number 1595675 120514 16:17:59 [Note] 120514 16:17:59 mysqld_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended
I searched a lot about this but could not get the solution. Any help will be apprisiated Thanks