When I tried to build and run, Xcode said my device was locked. I looked at my iPhone, and it's not locked at all. How do I fix this?

lock it and unlock it againChrisH
tried it, still no luckFaisal Syed
For me, unplugging and re-plugging did the trick. No need to Clean Build Folder, restart Mac with Command+Option+P+R, leave the house and come back again, burn a Voodoo doll of Steve Jobs, etc.Nicolas Miari
I solved this issue with disabling hotspotlevye
@NicolasMiari For me it has not worked and I am looking for the Voodoo dollzirinisp

30 Answers


Did you by chance not "trust" the device? This will prevent it from communicating with xcode even if the device is unlocked.

Update here's a support doc from Apple: http://support.apple.com/en-us/HT5868


My phone was set to "trust" the Mac, and I still ran into this error with Xcode 6.1.1.

This worked for me:

  • unplug device
  • quit xcode
  • open xcode
  • plug in device
  • build/run

I recently ran into this issue with XCode 8 just after updating my device from iOS 9 to 10. The exact error I received was:Development cannot be enabled while your device is locked. Please unlock your device and reattach. I received this error even when my phone was unlocked, and after unplugging and re-plugging in the device.

As is mentioned in several answers, the device is locked message is actually referring to the device not trusting the MacBook. In my case, I think my phone defaulted to not trusting my computer after updating to iOS 10. Here are the steps that worked for me to reset the settings (this is the same process that is mentioned in the Apple support page in tehprofessors' answer):

  1. Disconnect your device from your MacBook and close Xcode.
  2. On your device go to Settings > General > Reset, then tap Reset Location & Privacy
  3. Plug your device back into your computer, and on the device you will be prompted to trust the computer. Tap trust.
  4. Now reopen Xcode and rebuild the project.
  5. The device locked error should disappear.

From the Window Menu in top bar of Xcode, select Devices and Simulators.

(or Press SHIFT + COMMAND + 2)

Then select your device, right click and select Unpair.
Once you do this Trust or Don't trust will appear on your device.
Trust the device again and it will begin preparing it for Development.
Wait for Xcode to pair device for development and then you are good to go!


I ran in to the same issue even though i selected "Trust this computer" option first time.

This worked for me

  1. Lock the device
  2. Remove cable from device.
  3. Unlock the device
  4. Connect again to Mac


The fastest way for now i found is:

1) Go to Window -> devices (changed the hotkey in xcode to CMD+P for me)
2) Press unpair on the device. enter image description here
3) Press trust in iPhone.
4) Build again or Run without building (Ctrl+CMD+R)


For anyone who need a logical answer..

  1. Go to Window -> Devices & Simulators. Right click on your device & unpair it.
  2. Disconnect from cable & reconnect.
  3. Wait for it & let Xcode detect you device.
  4. Run the project.
  5. Make sure you TRUST on your iOS device and enter any passcode.

Rebooted my iPhone, and that fixed it for me.

I tried every answer on this page (7 at the time, though 2 are duplicates) and they were all unsuccessful for getting rid of this Xcode error for me.


I have a very simple solution which worked for me instantly. Takes some 10 sec to do:

1) Go to Window -> Devices & Simulators and untick Show as run destination

enter image description here

2) Unplug the cable and plug it back in.

3) Run the project.

This should be solving your problem!


For those who has this issue in Xcode 9: Simply restarting Xcode should solve the problem.


This happens at times while using Xcode 9.


There are multiple solution to this as mentioned below :

Note : Make sure that your device is not locked when Xcode is trying to install app.

Solution 1 :

i. Disconnect device and connect again

Solution 2 :

i. Restart you device

Solution 3 :

i. Disconnect device

ii. Quit Xcode (Shortcut key : cmd + Q)

iii. Open your project

iv. Clean project (Shortcut key : cmd + shift + K)

v. Now connect device

vi. Run your project

For me Solution 3 worked perfectly


A simple solution:

  1. First, unplug your device.

  2. Now, unlock your device and plug it in again. Be sure that the device is unlocked.

  3. Now run the Xcode project by selecting the device as target.


When you plug in your iPhone, it will ask you to trust the computer. If you already trust and unlocked but still said your device was locked (bug). Just unplug and plug again then it will work


These steps worked for me in iOS 10.

  1. Remove the cable from device.
  2. Plug in the device.
  3. Clean and build the Xcode project.

I run into this problem quite often (at least like 5 times a week). Almost every time this happens, a Xcode restart fixes it. But this time nothing seemed to work including:

  • Restarting Xcode;
  • Unplugging and re-plugging the iPhone;
  • Cleaning the project (cmd+shift+k);
  • Cleaning derived data (cmd+option+shift+k)

Done dozens of times in all sorts of different orders.

What fixed the issue for me this time was simply:

✅ Rebooting the Mac.


Recently I have met the Xcode shows "development cannot be enabled while your device is locked, Please unlock your device and reattach. (0xE80000E2).

If your iOS device is already unlocked and connected to mac and still get the error from Xcode 8.1 after upgrading to iOS 10.1.1, then the mac is not trusted by the device.

To fix it, first disconnect device to mac and then go to iOS settings app, and open general->reset->Reset Location & Privacy.

Then connect device to mac and when prompted, set select trust the mac.

Then wait the processing symbol files within your device and mac. After it finished, you can run the project to your device. It will be working.


This issue is not about "Trust" or not. It's a bug in Xcode.

Just follow these steps.

When Xcode is running and your device is connected:

  1. Lock your device.
  2. Unplug your device from Mac.
  3. Unlock your device.
  4. Plug your device back to Mac.

Solution: Switch target device to some other (e.g. Generic iOS Device),

enter image description here

then unlock you physical device and switch back to it again.


There is a simple way to resolve that. At least it works for me. In your iPhone Device Go to Setting > Developer > click in “Clear Trusted Computer” Type the passcode required And done!!!

The simplest way that I found.


Generally just unplugging/replugging seems to work for me. But today it didn't and something else seems to have worked: I have enabled network debugging on the device in question and it almost looked like it remembered an old network "lock" setting, while not seeing that the device was actually connected via USB. After (temporarily) de-selecting "Connect via Network" and replugging, it got things working again.


there are two solution worked for me. 1) disconnect your device from the mac and reattach it. 2) disconnect your device from the mac and restart it and then connect it with mac it'll work


Lots of answers, but the one that worked for me (El Capitan, Xcode 8.2) was to close iTunes. If that has a connection to the IOS device then although Xcode can load the app components it will still fail to run it.


On your device (iPhone/iPad) goto: Settings -> Developer -> Clear Trusted Computers worked for me.


I found that by shutting down a Console and a running Simulator allowed XCode to see my iPhone again. I'd make sure other related programs aren't running if you don't need them.


This can also happen due to pending update on your device. This also means you need to update your phone, connect to the MacBook (trust it if needed). This how I found my problem and solution.


One possibility worth checking, if none of these other solutions work, is that there is no space left on the device. Xcode will not give you a helpful "device full" error to tell you that your device has no storage space left, but it will also not be able to deploy an app build to a device whose storage is full. The only solution in that situation is to delete media or other apps/data to free up enough space.


sometimes your device stops trusting your PC for no reseaon. go to your settings then general > reset > reset location and privacy. and replug your device to your PC again and press "trust this device" prompt that shows up in your phone.


Another fix to this problem is to connect your iPhone with your Xcode open while your iPhone is in the homescreen, not in lockscreen or with an app opened.


All the previous solutions didn't work.

Finlay, changing the iPhone's cable solved the problem.


I had to re-add device to xcode.

In XCode open Devices and Simulators (CMD+Shift+2), in left list press + button and re-add the same device.