when I deploy adventure works cube it fails, and i get: user does not have permission to create a new object in 'GARY-PC', or the object does not exist. trying to process cube from adventureworks DW and having what seem like permissions issues (?). took following steps (i am using sql server 2008 R2 developer edition and VS 2008): 1 downloaded and successfully created adventureworksDW (2008R2) database from 2 successfully created Datasource and DSV for a cube with 2 fact tables and several dimensions. 3 Click deploy

I see the following 2 prompts Login: greyed out, can’t type anything here the password is required for the impersonation account of data source Adventure Works DW.

Now, Whether I enter a password or not, I get: Error 3 Either the 'Gary-PC\Gary' user does not have permission to create a new object in 'GARY-PC', or the object does not exist. 0 0

what objects is SSAS trying to create? are these objects in the relational database?


6 Answers


You have to add your user account as an administrator in the Analysis Services portion of the SQL server.

For some reason the database and the analysis services portion of the server do not share login information. The user you run Visual Studio under needs to have administrative access to the Analysis Services engine; this is the reason running as administrator works. The account you use to access the Database Engine is arbitrary.

  • Right-click on the SQL Server Management Studio icon and then select "Run as Administrator"

  • Select "Analysis Services" from the "Server type:" drop-down list in the "Connect to Server" dialog box, then click connect.

  • Right-click on the localhost definition in the Object Explorer panel and select Properties.

  • Click on Security in the left panel of the Analysis Server Properties.

  • Click the Add... button and type your user name and click the Check Names button to make sure you typed it right. Then click OK.

  • Click OK.

Note: This may not the most secure solution, but it enables not running Visual Studio as administrator every time and possibly opening up yourself to attack.


The Error message is:

"domain\user does not have permission to alter object 'mf20'..................."

I gone through the work around and found the solution as below:

Open Services, go to Analysis services--->right click on it --> Properties-->LogOn --> select This Account -->give server and your user name here. confirm it is your user, click ok.

Stop the service and again start the service. check the service Log On As in your user name.

That's it. save your cube in BIDS and close and reopen the cube, then deploy the cube. it will deploy and process it.

I hope this will help.


I had the same exact issue, but I was using the Adventure Works DW 2012. The problem is not on the database end but how your trying to deploy. When you run BIDS (or SQL Data Tools 2012 or Visual Studio 2010) use the "Run as Administrator" menu option. It will then ask you to authenticate, but the authentication should be accepted.


The user account you're using to deploy the SSAS database must have appropriate access to the SSAS instance in order to create the database and objects inside. Since this is a dev-setup, you could try adding your user account to the Server Admins.

In SSMS, log into the SSAS instance and right click on it (in the object explorer) and select properties. The last option in the left-pane is security and here is where you can add admin users.


are you talking about the " impersonation information" tab when you double click on the data source ? You should set it to "use service account"


In BIDS Solution Explorer → select the (in my case xx=08) Data Source and double-click on it. From the Data Source Designer screen click on the “Impersonation Information” tab, and enter the username and password of the user who has access for that remote data base or data source, and click OK.